Bug 2374 - Get dependency graphs working
Summary: Get dependency graphs working
Status: RESOLVED FIXED
Alias: None
Product: Infrastructure
Classification: Unclassified
Component: Bugzilla (show other bugs)
Version: unspecified
Hardware: All All
: P4 - Within a month normal
Assignee: Børre Gaup
URL: http://giellatekno.uit.no/bugzilla/sh...
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-05 10:08 CEST by Sjur Nørstebø Moshagen
Modified: 2017-04-05 12:09 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sjur Nørstebø Moshagen 2017-04-05 10:08:29 CEST
To repeat, click the link in the URL field above. Notice how the graph shows up as a question mark icon.

The cause seems to be that we are using a very old version of the dependency graph code, which is pointing to an unaccessible AT&T server. What we should do instead is to use a local installation of the software required to generate the graph. There is a long discussion of this bug at https://bugzilla.mozilla.org/show_bug.cgi?id=154500 (from 15 years ago!). I am sure there are working solutions out there now.

See also Graphs section in the Bugzilla documentation: https://bugzilla.readthedocs.io/en/5.0/administering/parameters.html#graphs
Comment 1 Børre Gaup 2017-04-05 12:09:55 CEST
(In reply to Sjur Nørstebø Moshagen from comment #0)
> To repeat, click the link in the URL field above. Notice how the graph shows
> up as a question mark icon.
> 
> The cause seems to be that we are using a very old version of the dependency
> graph code, which is pointing to an unaccessible AT&T server. What we should
> do instead is to use a local installation of the software required to
> generate the graph. There is a long discussion of this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=154500 (from 15 years ago!). I
> am sure there are working solutions out there now.
> 
> See also Graphs section in the Bugzilla documentation:
> https://bugzilla.readthedocs.io/en/5.0/administering/parameters.html#graphs

Installing graphviz and webdot and pointing said parameter to /opt/local/bin/dot fixed this issue. 

The above link works now