Bug 193 - oa->å dipht. simpl. in actor nouns
Summary: oa->å dipht. simpl. in actor nouns
Status: RESOLVED FIXED
Alias: None
Product: smj morphophonology
Classification: Unclassified
Component: Rule component (show other bugs)
Version: unspecified
Hardware: Macintosh MacOS X 10.3
: P2 - As soon as possible normal
Assignee: Trond Trosterud
URL:
Keywords:
: 189 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-29 09:57 CEST by Thomas Omma
Modified: 2007-09-13 07:40 CEST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Omma 2005-09-29 09:57:03 CEST
Concerns actor nouns from e-stem verbs.
In front of i there should be dipht simpl. This works with words like oade, which is in grade I, for 
example:
oadet+V+Actor+N+Sg+Com
Comment 1 Thomas Omma 2005-09-29 10:23:43 CEST
Dipht simpl works when there are geminates too:

loagget+V+Actor+N+Pl+Gen
låggij
Comment 2 Thomas Omma 2005-09-29 11:39:19 CEST
*** Bug 189 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Omma 2005-10-03 08:26:14 CEST
I understand Spiik this way: 
Grade I and II: diphtong simpl. before stem vowel -i-.
Grade III: no diphtong simpl. before stem vowel -i-.

This means that words boahtit->boahtte oadet->oade behave like they should do, but not loagget-
>loagge
Comment 4 Thomas Omma 2005-10-11 12:51:46 CEST
A few testing examples after our G1-2-3 implementation. The should-be-forms in parenthesis.

boallo+N+Dim+N+Ess
boalutjin                       (bålutjin)

roavggo+N+Sg+Ill
råvgguj                        (roavgguj)


goarrot+V+Ind+Prs+Sg3
goarru                          (gårru)
goar'ru                         (RIGHT)

goarrot+V+Ind+Prs+Du1
goarrun                       (gårrun)
goar'run                      (RIGHT)



Comment 5 Thomas Omma 2005-11-02 14:26:10 CET
For our first testword it fails here:
toabmot+V+Pass+V+Inf
toamudallat

While for our second testword it does not fail with -dallat but in short passive:
oadot+V+Pass+V+Inf
oadut
ådudallat

This is not right either:
roavggo+N+Sg+Ill
råvgguj

roavggo+N+Dim+N+Ess
roavgutjin



Comment 6 Sjur Nørstebø Moshagen 2005-11-03 15:09:30 CET
Can you Thomas test all problem words, and check that they all go through now? And if so, you can also close the bug itself:-)
Comment 7 Thomas Omma 2005-11-04 11:16:35 CET
After some revisions to our "major revision" oa:å dipht. simpl. now works with stem-vowel -o - except for words with geminates=serie 2 in Spiik. Next step is therefore to deal with this.

We definitively made a major leap forwards with our revision. There are however some other things too that we have to deal with before we can close this bug:

oa:å dipht simpl. with other stem vowels than -o

æ:e dipht. simpl.

These will now be my prioritees.
Comment 8 Thomas Omma 2005-11-05 16:00:35 CET
It does not work with the central consonants gg:kk, dd:tt, bb:pp either: Series 6 in Spiik.
Comment 9 Thomas Omma 2005-11-05 16:26:19 CET
It does not work with the central consonants dtj:ttj, dts:tts: Series 5 in Spiik.
It does not work with the central consonants ks:vs etc. either: Series 7 in Spiik.
Comment 10 Thomas Omma 2005-11-07 10:55:59 CET
It does not work with the central consonants rssk or jsst either. These are series 3 in Spiik. Other series 3 work though
Comment 11 Thomas Omma 2005-11-08 09:51:24 CET
These do not work for S1:
ssjk:sjk
ssjm:sjm
ssjv:sjv

S3:
jsst:jst
lssk:lsk
msst:mst
nssk:nsk
nsst:nst
rssk:rsk
rssjt:rsjt
vsst:vst
Comment 12 Trond Trosterud 2005-11-08 10:05:56 CET
rssk and jsst:
Here, I am not able to copy your failure. I did as follows: I copied the Alphabet, Sets and Definitions sections of twol-smj.txt over to a different file. Then I wrote a new Rules section, containing only the rule
"Test"
a:b <=> _ LowerG12 a ;
Then I opened the resulting file in twolc, compiled and tested:
prompt$ twolc -utf8
read-grammar test.txt
compile
lex-test
arska
arrska
etc.

I found a:b change for G2, but not for G3, as intended, also for these two consonant sequences. For these two, I thus predict that our rules should work. Also, all the G3 strings Thomas claims to be malfunctioning in his last posting work for me.

dtj, dts, ks, kt, ktj, kts, bb, dd, gg are all flawed, though, as they were not part of our initial setup. I will look into the issue.
Comment 13 Trond Trosterud 2005-11-08 10:17:53 CET
This was not easy. I try to subtract the set of two-phoneme G3, like this (I also tried make all of them :lower):

 LowerG2  = [[ (Cns:0)  LCnsPhon (Cns:0) LCnsPhon (Cns:0) |
              (Cns:0) [[[:j|:l|:m|:n|:v] :s :t ] |
              (Cns:0) [:l|:r] :s :k |
              (Cns:0)  :r :s :j :t ] ] - [ [d t [ s | j]] | b b | d d | g g | k [ s | t | t j | t s ] ];

The message I get is:
Alphabet... Sets... Definitions...parse error at 's ] ];'
Comment 14 Thomas Omma 2005-11-08 10:55:26 CET
Here are the test results that I get for the S1:s:
boassjko+N+Sg+Ill
boassjkuj                          G3

boassjko+N+Sg+Com
boasjkujn                          G2  (WRONG)

And S3:
boajssto+N+Sg+Ill
boajsstuj                           G3

boajssto+N+Sg+Com
boajstujn                           G2   (WRONG)
Comment 15 Trond Trosterud 2005-11-08 11:19:39 CET
It seems one alternative could be to define the respective sets positively, i.e., not as something which is two and not three consonants, but rather as the full list of G2 sequences. Also, the subtraction could come at the two-consonant-definition level.

I now did this, and the resulting automaton fixes both the earlier reported issues, and Thomas' last posting (in my truncated test version, that is, but at least we now are able to distinguish between G2 and G3 in a reliable way).
Comment 16 Trond Trosterud 2005-11-08 11:20:55 CET
The relevant definitions now are:
Sets
 Cns1 = b    c d    f g       h       j k l    m       n       ñ p q r    s t v w x z   ;
 Cns2 =      c      f         h       j   l    m       n       ñ p q r    s t v w x z   ;
 Cns3 =   b3     d3     g2 g3   h2 h3       l3   m2 m3   n2 n3         r3             ' ;
 Cns  = b b3 c d d3 f g g2 g3 h h2 h3 j k l l3 m m2 m3 n n2 n3 ñ p q r r3 s t v w x z ' ;

Definitions
 LCnsPhon1 = [ :Cns1 | :n :j | :s :j | :t :j | :t :s ] ;     ! Using Cns1, excluding 1st member of two-cns G3
 LCnsPhon  = [ :Cns2 | :n :j | :s :j | :t :j | :t :s ] ;     ! Using Cns2, without the previous restriction

 LowerG2   = [[ (Cns:0)  LCnsPhon1 (Cns:0) LCnsPhon (Cns:0) |
                (Cns:0) [[[:j|:l|:m|:n|:v] :s :t ] |
                (Cns:0) [ :l | :r ] :s :k |
                (Cns:0) [ :b (Cns:0) [ :d | :m | :j | :l | :n | :n :j | :r | :s | :t :j | :t :s  ]
                        | :d (Cns:0) [ :j | :n | :n :j ] | :g (Cns:0) :ŋ | :k (Cns:0) [ :n :k ] ]
                (Cns:0)  :r :s :j :t ] ] - [ [d t [ s | j]] | b b | d d | g g | k [ s | t | t j | t s ] ]];
 LowerG1   = (Cns:0)   LCnsPhon ;
 LowerG12  = [ LowerG1 | LowerG2 ] ;
Comment 17 Trond Trosterud 2005-11-08 11:27:37 CET
Well, it seems my test rule wasn't good enough. I now ran it through the test bed in the twol file itself, and got 6 errors, among them our dear låvda. According to my test bed, the G2 of vdd (i.e. vd) is identified as G2 (i.e., as a member of the LowerG12 set).

This is a mystery to me.
Comment 18 Thomas Omma 2005-11-08 16:58:28 CET
Current status:
S1 Everything working!
S3 Still the problem clusters:
jsst:jst
lssk:lsk
msst:mst
nssk:nsk
nsst:nst
rssk:rsk
rssjt:rsjt
vsst:vst
S4 Working
S5 Working!
S6 bb:pp and dd:tt working. gg:kk NOT working
S7 Working!
S2 For words goar'rot and goarrot it works BUT we have got problems with the derivations. Some ex:
goarrot+V+Actor+N+Sg+Ill
goarruj
gårruj      (should be goarruj)
goarrot+V+Der/(u/a/å)d+V+Inf
goarrudit  (should be gårrudit)
gårudit
goarrot+V+Pass+V+Inf
goarroduvvat
goarrudallat  (should be gårrudallat)
goarrut
goaroduvvat
gårrut           (should be goarrut)
gårudallat

Comment 19 Thomas Omma 2005-11-11 10:32:11 CET
I have now again tested ALL central cons. clusters and results show major succes! This means we only have the problem with the geminates in derivated words left: G2--->G3. Here we have the actor nouns with Dummys Y6 and Y7 and the short passive with Dummy Y9. But testing results indicate that we have got problems the other way round too: G3--->G2:
goarrot+V+Der/(u/a/å)d+V+Inf
goarrudit      (this should be gårrudit since it is G2, derived from the G3 verb goar'rot)
gårudit
Comment 20 Thomas Omma 2005-11-11 22:55:54 CET
According to testing last changes proves to be succesful! I have tweaked a little bit and I am still tweaking, but all in all we seem now to have just the G2>G3 thing left.
Comment 21 Thomas Omma 2006-05-16 10:02:49 CEST
So, I have now removed dummys Y6, Y7 and Y9 from rules on diphtong simplification oa:å and æ:e. This because of discovery that we have consonant gradation in Prs Part and Passives of words like oadet > oadde (PrsPart) > oaddut (Pass). G1 > G3.

Testing indicates that all is functioning, so I consider this case as closed if nothing unexpected happens.
Comment 22 Thomas Omma 2007-06-15 19:34:44 CEST
*** Bug 403 has been marked as a duplicate of this bug. ***
Comment 23 Sjur Nørstebø Moshagen 2007-09-13 07:40:17 CEST
I was trying to remove the duplication note on bug 403, but this was the wrong place. Sorry for the noise.