Bug 2574

Summary: Forrest kompilerer ikke for meg, java-feil
Product: Infrastructure Reporter: Thomas Brevik Kjærstad <thomas>
Component: Documentation infrastructureAssignee: Børre Gaup <borre.gaup>
Status: NEW ---    
Severity: enhancement CC: sjur.n.moshagen, trond.trosterud
Priority: P5 - Later    
Version: unspecified   
Hardware: Macintosh   
OS: Other   

Description Thomas Brevik Kjærstad 2019-04-03 13:45:22 CEST
U   forrest

Fetching external item into 'forrest/whiteboard/plugins/org.apache.forrest.plugin.input.odt/resources/stylesheets/common':
A    forrest/whiteboard/plugins/org.apache.forrest.plugin.input.odt/resources/stylesheets/common/odt_to_xhtml.xsl
Sjekket ut eksternt objekt på revisjon 1856870.

Sjekket ut revisjon 1856870.
dhcp1734-stud4:Documents thomas$ cd forrest/main
dhcp1734-stud4:main thomas$ ./build.sh
Using classpath: ../lib/endorsed/jakarta-bcel-20040329.jar:../lib/endorsed/jakarta-regexp-1.5.jar:../lib/endorsed/xalan-2.7.1.jar:../lib/endorsed/xercesImpl-2.11.0.jar:../lib/endorsed/xml-apis-1.4.01.jar:../lib/endorsed/xml-apis-ext-1.4.01.jar
Buildfile: build.xml

init:
Created dir: /Users/thomas/Documents/forrest/build

      --------------------------------------------------------------

      Using Apache Ant version 1.7.1 compiled on September 26 2008
      Build file /Users/thomas/Documents/forrest/main/build.xml
      Use 'build.[sh|bat] -projecthelp' to see other options.
      Build system home /Users/thomas/Documents/forrest/tools/ant
      Build number 0
      Project Name Forrest build file
      Java Version 1.6      
      Timestamp 201904031357
      This is: apache-forrest 0.10-dev

      --------------------------------------------------------------
    

compile:
Created dir: /Users/thomas/Documents/forrest/build/classes
Compiling 33 source files to /Users/thomas/Documents/forrest/build/classes
error: Source option 5 is no longer supported. Use 6 or later.
error: Target option 1.5 is no longer supported. Use 1.6 or later.

BUILD FAILED
/Users/thomas/Documents/forrest/main/build.xml:595: Compile failed; see the compiler error output for details.
Comment 1 Børre Gaup 2019-04-03 14:02:45 CEST
På linux, så fungerer byggingen for meg med meldingene nedenfor:

main $ ./build.sh 
Using classpath: ../lib/endorsed/jakarta-bcel-20040329.jar:../lib/endorsed/jakarta-regexp-1.5.jar:../lib/endorsed/xalan-2.7.1.jar:../lib/endorsed/xercesImpl-2.11.0.jar:../lib/endorsed/xml-apis-1.4.01.jar:../lib/endorsed/xml-apis-ext-1.4.01.jar
Buildfile: build.xml

init:
Created dir: /home/boerre/forrest/build

      --------------------------------------------------------------

      Using Apache Ant version 1.7.1 compiled on September 26 2008
      Build file /home/boerre/forrest/main/build.xml
      Use 'build.[sh|bat] -projecthelp' to see other options.
      Build system home /home/boerre/forrest/tools/ant
      Build number 0
      Project Name Forrest build file
      Java Version 1.6      
      Timestamp 201904031410
      This is: apache-forrest 0.10-dev

      --------------------------------------------------------------
    

compile:
Created dir: /home/boerre/forrest/build/classes
Compiling 33 source files to /home/boerre/forrest/build/classes
/home/boerre/forrest/main/java/org/apache/forrest/log/ForrestLogTargetFactory.java:22: warning: [deprecation] CocoonTargetFactory in org.apache.cocoon.util.log has been deprecated
import org.apache.cocoon.util.log.CocoonTargetFactory;
                                 ^
/home/boerre/forrest/main/java/org/apache/forrest/log/ForrestLogTargetFactory.java:30: warning: [deprecation] CocoonTargetFactory in org.apache.cocoon.util.log has been deprecated
    extends CocoonTargetFactory {
            ^
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
2 warnings

jar:
Building jar: /home/boerre/forrest/build/xml-forrest.jar

  *-----------------------------------------------------------------
  | Installation notice 
  *-----------------------------------------------------------------
  | You have now built the 0.10-dev version of Forrest.
  | Please set the environment variable FORREST_HOME to point to
  |  /home/boerre/forrest
  | It is recommended to add
  |    unix: $FORREST_HOME/bin: to your $PATH
  |    win: %FORREST_HOME%\bin; to your %PATH%
  | Then do 'forrest -projecthelp' to list options for the 'forrest' command
  | More help at http://forrest.apache.org/
  *-----------------------------------------------------------------
    

BUILD SUCCESSFUL
Total time: 1 second

Har du noe flere feilmeldinger? 

Legger til Trond og Sjur i CC-lista, de bruker Mac, kanskje de har noen innspill?
Comment 2 Thomas Brevik Kjærstad 2019-04-03 20:54:23 CEST
Jeg har prøvd både å installere en eldre Java-versjon, og å installere den nyeste versjonen på nytt, men jeg får disse uansett:
error: Source option 5 is no longer supported. Use 6 or later.
error: Target option 1.5 is no longer supported. Use 1.6 or later.